New question

Question:

Date: 19-08-2015 16:13:40 (In Spanish)

netbeans 8.0.2 abre carpeta y No ejecuta script php al debugging[Resolved]

Hola a todos

Tengo la pc reinstalada, todo desde cero.
Windows 7 pro.

Instale el java y netbeans 8.0.2

Cuando coloco un breakpoints en una linea y le doy al botón Debug Project abre el navegador (Fire Fox) y el contenido es una carpeta y no el script de PHP en donde hice el breakpoints.
El Script esta guardado en un proyecto llamado CURSO .

Le dejo capturas de pantallas.
1) Marco el breakpoints y le doy al boton Debug Project el triangulo grande verde.


2) se abre el navegador en la url: http://localhost/CURSO/misPruebas/


3) y el archivo que se debería ejecutar esta en la siguiente ruta y es index.php
E:\wamp\www\CURSO\misPruebas\POO\clasePOO\index.php


No sé que debo configurar para que ejecute el script que quiero hacer debugging
Y que configuraciones me serian útiles o convenientes hacerle al netbeens.

Muchas Gracias por la atención

Que tengan un buen día

Saludos

Tags: Debug - Microsoft - Netbeans - PHP - Question - Xdebug Votes: 0 - Answers: 8 - Views: 9 Share on: Google Facebook Twitter LinkedIn Link
 

Answers:

  • Date: 19-08-2015 18:21:17 Bueno
    creo que encontré la solución a ese problema con saetear estas opciones



    Ahora abre bien, pero cuando en el IDE netbeans paso el raton por las variables no se ven los datos que fue tomando.

    Por otro lado cuando le doy a Run proyect abre la carpeta que antes habia mencionado y no ejecuta el script
      Votes: 0 - Link answer
     
  • Date: 20-08-2015 05:22:45 El "play" lanza el proyecto segun la configuración realizada en "Project URL", parámetro que se configuró al momento de crear el proyecto (lo puedes cambiar haciendo botón derecho sobre el nombre del proyecto -> opción "Properties", en la sección "Run Configuration", como lo muestras en tu ultimo comentario). Ahora bien, para lanzar el debug de un archivo en particular, debes hacer botón derecho sobre el archivo y luego darle a la opción "Debug File".

    Saludos,
      Votes: 0 - Link answer
     
  • Date: 20-08-2015 07:06:58 Muchas Gracias Fernando por responder.

    1- si lo configure en las propiedades pero aun no me esta funcionando el debug.
    2- la opción "Debug File"
    Al hacer clic aparece el menu contextual


    Click en opción Debug
    aparece

    La ruta es correcta entonces le doy OK

    Abre el navegador con la URL:
    http://localhost/CURSO/?XDEBUG_SESSION_START=netbeans-xdebug

    Y muestra en la pagina:
    Index of /CURSO
    con el listado de Directorios y archivos, no ejecuta el archivo en cuestión.

    No se en donde esta el problema

    Saludos y gracias nuevamente
      Votes: 0 - Link answer
     
  • Date: 20-08-2015 16:21:26 Hola Walter, la ventana "Specify URL" te sale porque tenes configurado en las propiedades del proyecto ->sección "Run Configuration"-> botón "Advanced" la opción "Debug URL" con "Ask Every Time", tenes que cambiarlo a "Default: http://..........." y listo, ya no te va a volver a preguntar.

    Por otro lado, veo que en tu ventana de netbeans (abajo a la derecha) dice "Waiting For Connection (netbeans-xdebug)" <-- cuando se queda en este estado es porque no esta correctamente configurado el xdebug en XAMPP o el puerto del debug en Netbeans, te recomiendo que reveas la nota en la que explico Configurar XDebug en NetBeans (debug código PHP) y valides que este todo ok

    Por otro lado, asumiendo que esta funcionando correctamente el xdebug y que netbeans esta conectado con xdebug correctamente, ¿que pasa si una vez que lanzar el debug cambias la url "http://localhost/CURSO/?XDEBUG_SESSION_START=netbeans-xdebug" por "http://localhost/CURSO/misPruebas/POO/clasePOO/index.php"? (estoy asumiendo que tenes el break point en ese script).

    Saludos,
      Votes: 0 - Link answer
     
  • Date: 27-11-2015 13:04:30 Hola Walter, pudiste resolver este tema?

    Si todavía no pudiste, creá un script php que tenga la función phpinfo(); solamente y ejecutalo. En la página que te muestra podes buscar (Ctrl+F o Ctrl+B dependiendo el lenguaje y navegador) el texto "xdebug", tiene que estar listado ahí y habilitado, si no lo está ya sabemos por donde viene el problema.

    <?php
    phpinfo();
    ?>
    


    Luego reviendo tu anterior respuesta, veo que vos haces clic derecho sobre el archivo en el arbol del proyecto y ahí dice "Debug", no "Debug File". El texto "Debug File" aparece en el menú cotextual cuando haces botón derecho sobre alguna parte del código del archivo (no sobre el archivo). En cualquier caso no tiene importancia, porque las dos opciones hacen lo mismo.

    Saludos,
      Votes: 0 - Link answer
     
  • Date: 27-11-2015 13:51:43 Que opción era que había que destildar para qué la ejecución no valla paso a paso   Votes: 0 - Link answer
     
  • Date: 27-11-2015 14:04:55 Para que no se pare en la primera línea de tu script, solo que se pare en el breakpoint: la opción esta en Netbeans, menú Tools->Options->Solapa Debuggin->Opción "Stop at First Line ".

    Ya te funciona? (recorda cambiar el estado de la pregunta si es así)

    Saludos!
      Votes: 1 - Link answer
     
  • Date: 27-11-2015 18:22:39 con respecto a "xdebug" en phpinfo()

    Resulta:
    This program makes use of the Zend Scripting Language Engine:
    Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
    with Xdebug v2.2.5, Copyright (c) 2002-2014, by Derick Rethans


    xdebug
    xdebug support enabled
    Version 2.2.5
    IDE Key KAPRY$



    ya en el IDE destilde la opcion Stop at First Line

    y sigue presentando el mismo problema.
      Votes: 0 - Link answer
     
To actively participate in the community first must authenticate, enter the system.Sign In